Reenabling Force Touch for Painting

Andrius

Posts: 6

1 year ago

In Pixelmator 3.4, we added support for the Force Touch trackpad when using various brushes, for example with the Eraser Tool or the Brush Tool. We noticed it wasn't all that intuitive for most people so, with version 3.4.1, we've decided to remove it for now. But, we left a (secret) way to turn it back on. Here's how to do it:

1. Quit Pixelmator
2. Open Terminal

(To do that, you can press the Command-Space keyboard shortcut to open Spotlight Search, then start typing "Terminal" and press the Return key when Terminal comes up)

3. Paste "defaults write com.pixelmatorteam.pixelmator PXMEnableForceTouchPainting -bool yes" into Terminal and hit Enter
4. Launch Pixelmator

Don't worry, you don't need to know anything about the Terminal app to do this and you won't break anything. It's just a different way of changing the settings in Pixelmator.

As always, if you have any issues with this or Pixelmator in general – we're here for you. Just drop us a line at support@pixelmator.com and we'll get right back to you.
Jakester

Posts: 1

1 year ago

Please fix this feature ASAP! I purchased Pixelmator last night specifically for this feature of "force touch painting with trackpad" (which it was advertised as having) and now I find that it's not actually supported. :(

I tried the above "defaults write" and indeed it's awful; I could get some pressure sensitivity but had to really "mash" the trackpad to make any difference in the stroke width/flow.

Please sign in to post.