How to fill color selection with solid color

brockleus

Posts: 8

2 years ago

I've selected a pixel of color(white) for color selection from an image
and adjusted the radius for full selection of white and greys. When I
try to fill with red, it gives me gradients of red in the selection. I
only want a solid fill of red, no gradients, within the color selection and
in a new layer. I can't find a fix, please help!
Edita

Posts: 223

2 years ago

Hi brockleus,

You should be able to fill the selected area with the Paint Bucket Tool. Could you please upload a screenshot of how your image looks when you fill the selected area with red color? It would really help me see what's wrong. Here's a quick guide how to take a screenshot:

https://support.apple.com/en-us/HT201361

Thanks!
brockleus

Posts: 8

2 years ago

Image
brockleus

Posts: 8

2 years ago

Image
brockleus

Posts: 8

2 years ago

What I need:
Select color -> Adjust Radius (ok) -> fill (with a selected color) -> Cut (paste in new layer) -> delete original layer
Final image should be a hard edge outline/fill (with the selected color) of the color selection (as indicated by the dotted line) on a transparent background.
Sebastiaan

Posts: 3482

2 years ago

Hello Brockleus,

Please try the following,

1) Use select color to select the red.
2) activate one of the selection/marquee tools and ctrl+click inside the selection
3) From the menu that appears, click on Convert selection into shape.

You'll now get a new layer with your selection as a shape. Adjust the shape settings to your liking.
brockleus

Posts: 8

2 years ago

Hello Sebastiaan! You are the MAN!!!!! That is the solution I needed to finish my work! I sincerely appreciate your professionalism and help! Wow! I am so thankful, I was beginning to believe this was going to be impossible. I guess we can say that you made the impossible, possible! Thank you again for your outstanding expertise and help in the matter!
jbanchy@gmail.com

Posts: 1

1 year ago

I recently upgraded to OS X El Capitan and Pixelmator 3.4 Twist. Since these upgrades my brush tool is not behaving the same way. When I draw the outside of the brush is a slightly different color. I don't seem to be able to paint a color color anymore. I don't know if there is something I changed accidentally in the settings or of some default is different in the products. The issue can be seen in the attached image where I am trying to draw in the red and you will see a lighter red brush outline.
Image

Please sign in to post.