Pixelmator for MacOS Lion 10.7.5

diopear

Posts: 2

3 months ago

Hello,
What the latest version of Pixelmator for MacOS 10.7.5 and how can I download It? When I try to download from App Store, show me this message (attachment).
Thank you!

Diogo
Image
Sebastiaan

Posts: 3528

3 months ago

This is correct. Like it says, Pixelmator requires Mac OS X 10.10. You're running an older version of OS X, version 10.7
diopear

Posts: 2

3 months ago

Hello Sebastiaan,

Do you can provide me a private link to download the latest version of Pixelmator compatible with MacOS 10.7.5?
*I posted here, in the forum, because I didn't have an answer by e-mail.

Thank you!

Diogo
Sebastiaan

Posts: 3528

3 months ago

I'm terribly sorry but I cannot do that. The older version of Pixelmator are no longer supported, nor is your OS X version.

If you have a proof of purchase you might be able to get someone else in the team to send you an older version. Try sending this proof of purchase to support@pixelmator.com

Please sign in to post.