"unidentified developer" message

dshillis

Posts: 6

1 year ago

I am trying to make Pixelmator the default application for .jpg & .tiff files. As I control-click on a file, choose Open With > Other..., select Pixelmator and check the box "Always Open With," I get the message "<file> can't be opened because it is from an unidentified developer." Currently I have my security preferences set to allow apps from the Mac App Store & other identified developers (to be safe), but I bought this app from you IN the Mac App Store. I cannot understand why I keep getting blocked here?
Motiejus

Posts: 885

1 year ago

Hey dshillis,

It's actually expected behavior and happens with pretty much any other OS X app, except Preview. That's basically because Preview simply opens the file to be viewed, meanwhile, opening it in any other app might mean you're willing to edit it in any way. Since the JPEG, or in fact any other format file was not obtained from the Mac App Store or any identified developer - you're seeing this message. That's simply how Mac handless it's security settings.
Pixelmator Team
dshillis

Posts: 6

1 year ago

I've never experienced this issue before. Show how do you reset the defaults for files like .jpg, .tiff, .png, so that their default open application is Pixelmator?
Motiejus

Posts: 885

1 year ago

You could actually allow the files to be opened in Pixelmator, or any other app, by clicking the "Open Anyway" button in System Preferences > Security & Privacy. This should solve it.
Pixelmator Team
dshillis

Posts: 6

1 year ago

In El Capitan, I don't see any such button under Preferences > Security & Privacy. I looked through all the tabs in there, perhaps I missed it, but I'm not seeing it.

The original question is, however, how to get Pixelmator to be the default application for opening .jpg and .tiff files? The process I was trying should have been the way to solve it, but the "unidentified developer" warning was preventing it.
dshillis

Posts: 6

1 year ago

Does this only work in Yosemite? Did the setting move?
Motiejus

Posts: 885

1 year ago

The approach you're using to make Pixelmator the default app for these type of files is correct, it's just the security settings that were enhanced in the latest OS X release what makes it a bit complicated. If you're not seeing the "Open Anyway" button in the System Preferences > Security & Privacy tab, click the Lock button located in the bottom left corner to unlock the changes, then, select the Allow apps downloaded from option as Anywhere. This should help.
Pixelmator Team
dshillis

Posts: 6

1 year ago

Sorry, incorrect. I'm not sure why this isn't working...at least on my system running El Capitan 10.11.2.

I unlocked and changed to anywhere, no button appeared called "Open Anyway." I can control-click on a .jpg file, for instance, choose Open with > Other... and then choose Pixelmator and then check the "Always Open With" checkbox. It then opens the file, but it only makes that particular .jpg file open automatically with PIxelmator. All other .jpg files still open with Preview.

I tried doing this with the "Allow apps downloaded from..." setting in System Preferences > Security & Privacy set to "Anywhere" as well as set to "Mac App Store and identified developers" but it doesn't change anything with this problem.
dshillis

Posts: 6

1 year ago

OK, here are the correct instructions... I found it on another website.

Step 1. Right-click on a file you would like to change the default app to open for.
Step 2. Click on Get Info.
Step 3. Locate and click on the Open with and choose the app you want to use as the default from drop-down menu.
Step 4. Click on Change All button, and click on the Continue from the pop-up window.

More info, including pictures, athttp://www.imobie.com/support/change- ... -files.htm.

Please sign in to post.